Hi all,
Shot in the dark, but since I know a few folks on here use SDR Console, I figured I'd post this recent issue I had on here to see if anyone has experienced similar.

I recently took a trip to a remote part of Virginia to make some IQ recordings to potentially capture some meteor scatter on the FM broadcast band. For the most part, mission accomplished! I used the Airspy v2 and SDR Console version 3.0.27 on the laptop I had for the day. The laptop is running Win 10 and had ample resources, writing to an external USB 3.0 drive. In Console, I just used the option to record single file RF 64 WAV files as the IQ output. This worked for 9 of the 11 sessions I ran during the period. Two of the sessions, however, are not playing back in Console.

The first issue is that when attempting to open up the two sessions, one being three hours in length and the other being two hours in length (approximately), Console just shows the files as 0 seconds long. It also shows the files as 5 MB in size. In reality, the files are 383 GB and 215 GB in size respectively. (See attached screenshot of how the two files appear in Console while trying to open them)

If I try to playback either of the two IQ files in the Console 'Data Playback' area, the frequency spectrum view does populate, and I hear about a half second blip if I try to begin payback, and then playback immediately stops.

The files do not load anything in the Data Analyser. If I try to use the IQ File editor on them, they also show as 0 seconds long in the IQ File Editor as well.

This appears to be related to perhaps missing metadata or an info chunk? The other IQ recordings I made in Console all have a title, contributing artist, album, and also show a duration if I right click on the properties of the files in Windows and look at the 'length'. The two IQ recordings in question have a length of 0 seconds.

Perhaps irrationally, I strongly believe there is a way to fix these files, as the data IS there. Has anyone ran into this problem with RF64 recordings? I tried this tool (https://github.com/jheidel/rf64-convert), but it looks more for converting rather than repair, and the issue(s) persist even with a new version of the files this script comes up with.

I would be extremely, extremely grateful for any insight anyone may have, as I really, really want to be able to access these recordings. Please let me know if any further information might be useful!
Attached Files